Personal View site logo
Make sure to join PV on Telegram or Facebook! Perfect to keep up with community on your smartphone.
GH2 can I get 24p quality with 25p recording?
  • I am looking for a high quality spanning 25p patch (to avoid flickering during recording because of theatre lights) to mix with my gh3 (pal version), tried cake 2.3, recorded a theatre show (HBR), but the difference in quality, with gh3 (25p, 50mb IPB) was pretty large.

    I did a test (24p and HBR) with cluster x spizz, see images below;

    The difference in quality between 24p and HBR (less detail, more aliasing) is something I see in all patches, can it be fixed with different settings or patch?

    spizz 24p.png
    1920 x 1080 - 2M
    spizz HBR.png
    1920 x 1080 - 2M
  • 19 Replies sorted by
  • No. Only with external recording.

  • Boom, clear answer, that makes me want another gh3!


  • Both the GH2 and the GH3 record 25p video differently than 24p. In both cases, the sensor is scanned progressively at either 24fps or 25fps. However, with 25p, the AVCHD encoder first divides each progressive frame into an interlaced pair of 1920x540 fields. It then encodes the even field like an I-frame, and the odd field like a P-frame. Subsequent frames within each GOP are likewise encoded as pairs of P-fields or B-fields. This makes the 25p video compatible with European 50i broadcast standards.

    The side-effect of this interlaced encoding technique is the possibility of introducing spurious interlace artifacts in decoded video renders. The GH2 fails to embed the proper metadata within its 25p and 30p HBR files to flag them as containing progressive video streams within an interlaced container. As a result, there is no explicit way that a video editor can distinguish GH2 HBR 25p files from FSH 50i files. In Adobe After Effects, for example, it is necessary to manually turn off the Separate Fields property in the Interpret Footage dialog of each imported HBR file to avoid spurious interlace artifacts.

    With all that in mind, I invite you to try the HBR patch in Flow Motion v2.02. To minimize interlaced encoding discrepancies, I explicitly crafted its I-frame scaling tables to use the same encoding quality on P-fields as on I-fields. This produces results that in many of my test cases have been visually indistinguishable from 24p videos. I've included links to downloadable samples here:

  • " is necessary to manually turn off the Separate Fields property in the Interpret Footage dialog of each imported HBR file to avoid spurious interlace artifacts..."

    Thx man, that helped a lot!

  • HBR mode is harder to hack than 24p mode. HBR mode quality won't be quite as good as 24p, but it can come pretty close for typical shooting scenarios, assuming you interpret the footage correctly like lpowell said. The sample HBR frame you posted is only showing one field.

  • By setting the seperate fields property to off I got rid of the so called "spurious interlace artifacts", it introduces 'normal' interlacing artifacts though (in fast moving areas).

    Just been reading this:

    Do I now need (or benifit from) for example re-visions Deinterlacer, or is there another way to deal with the interlacing artifacts..

    So the gh3 does embed proper metadata? Because when I import that into after effects, seperate fields is already set to off, but why don't I have interlacing artifacts with the gh3 footage?

    @balazer, how do you actually see the HBR frame shows only one field?


  • When HBR footage is interpreted properly, you should see little or nothing resembling interlacing artefacts. Can you post a raw MTS file for us to look at? It is not really an issue of metadata. There is no metadata for AVCHD to say that the video originated in progressive but is formatted as interlaced. It is just something that you have to know about the GH2's HBR footage, and manually tell your software to change the formatting back to progressive. GH2 24p footage and GH3 footage is already formatted as progressive, so there is no issue for those.

    Try playing your footage in VLC. Pause it and step through frame by frame, and see if it looks any better than in your NLE. VLC by default will interpret all frames as progressive, which is the right way to handle HBR footage.

    I could tell that your still frame was a single field because it was only showing half vertical resolution. Every other line was a duplicate of the line above it.

  • "...turn off the Separate Fields property..." - does anybody know if there is a similar switch in FCP7? Thanks.

  • @balazer!797&authkey=!AM2e0bBOTzAuw6M

    a little piece of footage trimmed with tsMuxeR, so should be original.

    When I set seperate fields to off in after effects, quality increases and I get rid of the 'spurious interlace artifacts', but it introduces 'normal' interlacing artifacts (where there is normally motion blur, there are now lines..)

    Its a bit strange though, with other gh2 25fps clips I recorded I don't get interlacing artifacts as soon as i set the seperate fields to off; is it a wrong recording mode I choose for this particular recording session?

    thanks for your help by the way!


  • You should inspect your footage frame by frame. With Flowmotion I get sequence of interlace artifacts (because of 3 GOP structure?): 1 frame - no interlace artifacts
    2 frame - interlace artifacts
    3 frame - interlace artifacts
    4 frame - no interlace artifacts
    5 frame - interlace artifacts
    6 frame - interlace artifacts
    and so on.. every 3d frame has no interlace artifacts. Sample sequence of shots: Flowmotion HBR25, shutter 25

    Sequence 02.Still001.png
    1920 x 1080 - 3M
    Sequence 02.Still002.png
    1920 x 1080 - 3M
    Sequence 02.Still003.png
    1920 x 1080 - 3M
    Sequence 02.Still004.png
    1920 x 1080 - 3M
    Sequence 02.Still005.png
    1920 x 1080 - 3M
    Sequence 02.Still006.png
    1920 x 1080 - 3M
  • @Alex_K I'm not sure what you're referring to as "interlace artifacts", as I don't see any evidence of that in your still frames. In Flow Motion v2, as in all GH2 HBR patches, progressive B-frames and P-frames are encoded as separate B-fields and P-fields. When you turn off the Separate Fields flag in After Effects, it combines the fields into complete frames, eliminating interlacing artifacts.

    I don't have a GH3 and I'm not sure whether its 25p and 30p are flagged with the proper metadata to indicate that they contain progressive video streams embedded in an interlaced wrapper. I know the Panasonic AF100's 25p and 30p MTS files are flagged properly, and After Effects has no difficulty distinguishing them from true interlaced video files.

  • @LPowell May be i'm doing something wrong, but this are stills from Premiere pro after i interpret footage as progressive.

    1215 x 1134 - 221K
    1920 x 1080 - 67K
    715 x 492 - 56K
    1920 x 1080 - 64K
  • @manstok, your clip is true interlaced, not progressive segmented frame. It was recorded in 1080i mode, not HBR mode.

    @alex_k, I believe those artifacts are the result of the way the GH2 compresses the field pictures separately in HBR mode. It might help a little to use different hack settings, but what you have does not look too bad to me. Check frame-by-frame in VLC and see if it looks the same, to rule out an interlaced chroma upsampling bug in Premiere.

  • @balazer Interesting, but for me Still001 frame (I-frame?) has coarser noise/compression. Stills 002 and 003 (P&B) look smoother/better (noise is smoother). Look at face/skin. So, may be long GOP will be better with HBR

  • Maybe. I believe driftwood has GOP6 settings for HBR mode, and I've also experimented with longer GOPs for HBR 30p mode.

  • @Alex_K I'm not sure what the cause of the discrepancies you're seeing is, but it's not due to any flaws in the GOP structure of your MTS files. When using magnification in Premiere and After Effects, I've often found it tricky to insure that they don't apply gratuitous pixel-smoothing, particularly when altering the horizontal or vertical frame alignment. So I'd recommend double-checking your display settings in the Adobe option dialogs.

    As a reference, try downloading the following video from the Vimeo link. It's a 1080p30 HBR video taken in Flow Motion v2. Import it into either After Effects or Premiere Pro CS5.5 or CS6. Check out its Interpret Footage settings and you'll see that by default, it's interpreted as an interlaced video stream with the upper field first. If you step through the frames individually, you can see coarse diagonal edges on the rocks, regardless of which frame you examine. If you now set Separate Fields off (i.e. Progressive), you should see the vertical resolution double, eliminating the coarse diagonal edges in each frame.

  • Okay, getting to technical for me. From now on I will shoot HBR for my 25fps needs, no more 1080i because of interlacing=sucks. And in after effects set seperate fields to off. Thx bZ

  • @LPowell I don't see noticable artifacts In your reference. Those compression artifacts are barely visible. This is pixel peeping, i agree. FM is great. Just notice, that they depends on GOP length ) Here is my reference, to download.

    684 x 448 - 55K
    800 x 450 - 61K
  • FYI GH3 108025p IPB modes - truly progressive (no interlacing)

    Here's a good link for those who don't understand what's going on.

    25pIPB 50Mbps mode - Truly progressive.png
    856 x 1029 - 736K